PIEは、Podiumユーザーが、SketchUpを離れることなくポストプロセッシングやイメージ編集をPodiumレンダリングイメージにすばやく適用できるように作られました。ポストプロセッシング(後処理)とは、Podiumで作成したビットマップイメージに変更を加えることを意味します。たとえば、照明レベルや輝度の編集、イメージのクロップ、アルファ透過イメージへの背景追加、オーバーレイの追加、ブレンドなどはポストプロセッシング、あるいはイメージ編集機能です。

これまでポストプロセッシングを行うには、Photoshopのような高機能のイメージエディタが必要でした。PIEは、SketchUp上(Podium Rendering ManagerやOOPRから)での多くのポストプロセッシング処理を簡単にします。


PIEの使用法

Podium Image Editorの全機能についての情報は次のタブに掲載されています。

イメージをレンダリングしたら、Podium Render Manager、またはOOPRからPIEを起動できます。OOPRでレンダリングイメージの名前をハイライト表示し、編集をクリックします。

SU Podium V2 PlusのToolsメニューからPIEを起動することもできます。これはPIEを他に依存させずに起動する方法です。PIEが開いたら、編集したいイメージをOpen fileメニューを使ってロードします。

キャンセル: Podium Image Editor (PIE) には、実行した調整やフィルタを元に戻すアンドゥボタンはありません。ただし、行った編集は、Applyボタンを実際に押すまで確定されません。キャンセルボタンは、選択後実行した操作を取り消します。

適用: 適用ボタンは加えた編集を適用します。アンドゥは不可です。ただし、別のファイル名でイメージを保存すれば、誤って元のレンダリングイメージを永久的に変更してしまうのを防げます。

保存: 編集を永久的に保存する準備ができたら「保存」を押します。必要に応じて元のレンダリングに戻れるように、編集したファイルには新しいファイル名を付けて保存することをお勧めします。

色のついたヒストグラムは、どのようにRGBピクセルがイメージに分配されるかを表示する視覚ツールです。色調や光の明暗におけるイメージ合成の確認に役立ちます。イメージを実際に見るより多くの情報を提供します。グラフは編集するごとに更新されます。


自動レベル補正ボタンは、もっとも暗いエリアともっとも明るいエリアを中間トーンで均一化します。自動レベル補正を開始点として使用してレンダリングイメージの照明を調整します。

照明レベルスライダを使って照明を手作業で調節します。照明レベルスライダはイメージの暗いエリアや中間トーン、明るすぎるエリアを修正するのにも使用できます。これは、レンダリング時間を大きく短縮できる便利なツールです。照明レベルスライダを手作業で操作するのはたいていの場合、自動レベル補正ボタンよりも効果的です。

メモ: キャンセルを選択して元の照明レベルにリセットします。適用を選択した場合、イメージは永久的に変わります。Applyを選択する場合は、独自の名前でイメージを保存してください。

色のバランスは、レンダリングイメージの全般的な色を背景に一致させたり、エクステリアレンダリングから青味を除く、イメージ全体にもっと色を加える際に欠くことのできないツールです。

色機能にアクセスするために照明レベルに編集を加えた場合は、キャンセルをクリックしなければなりません。

3つのスライダがあり、各RGB値を設定します。スライダを中間から離すほど、イメージ全体の色が強まります。たとえば、作成したイメージの緑の色味が強い場合、色のバランスに満足がいくまで緑のスライダを左に動かします。同様に、(エクステリアレンダリングによくあることですが)イメージの青味が強い場合は、青のスライダを左に動かして、レンダリングにもっと黄色味を持たせます。

 輝度とコントラスト

3つのスライダは、レンダリングへの全体照明の量を簡単に設定できます。輝度とコントラストスライダはレベルスライダを使うより操作が簡単ですが、制御は低くなります。変更を、特定の色調だけでなく、イメージ全体に適用します。

輝度を右に動かすと、加える照明が増えます。輝度の量を増やすほど、イメージのコントラストは少なくなります。コントラストスライダを右に動かすと、加えるコントラストが増えます。これらの値を過度に上げると、途端にイメージが粗くなります。

ブラースライダはイメージをやわらかく見せます。ノイズをわずかに軽減するのに使用します。ただし、すべてのエッジがぼやけます。

一方、鮮明化スライダはすべてのエッジをはっきりと映します。またイメージの粗さ(ノイズ)を強調します。

背景タブに、透過アルファチャンネルでレンダリングしたPodiumイメージのエッジをクリーンナップするデフリンジ スライダが付きました。

これは常時必要な機能ではありませんが、透明イメージ(草木を多数有するものが多い)は、アルファチャンネルのエッジに沿って目立つ「フリンジ」が現れることがよくあります。

フリンジがイメージ上から消え始めるまでデフリンジスライダを動かすだけです。その後、適用をクリックして保存します。

Podium Image Editorは、.hdrファイルの読み込み/ロードが可能になりました。これで2つのことが可能になります。

  1. .HDRファイルは背景イメージとしてPodiumレンダリングにロードできます。
  2. .hdrフォーマットをつかってPodiumでレンダリングを作成する際に、そのイメージをPIEにロード/編集できるようになりました。

PIEには、.HDRの制限が2つあります。

  1. ただし、Podium Image Editorで.HDRにフォーマットに保存することはできません。.HDRレンダリングをPIEでロード/編集する場合、そのイメージは.jpgか .pngにしか保存できません。 PIEは.hdrファイルを再書き込みできません。

  2. PIEは.hdrを球形パノラマに変換できません。Podium Panorama serverにイメージをアップロードして変換しようとお考えの方は、.JPG、または.PNGを使用してください。

ビネッティングはイメージの周辺を変更します。負の値はイメージの周辺を暗くし、正の値は明るくします。

色相はイメージのすべての色を変え、彩度はすべての色を増やす/減らします。イメージを白黒にしたい場合は、彩度スライダを左端に寄せます。

このフィルタの主な役割は、フォトリアリスティックでないSketchUpイメージをPodiumでレンダリングしたイメージに重ねる、あるいはPodiumでレンダリグしたイメージの下に配置することです。これでSketchUpイメージのエッジラインを強調したり、エッジラインとPodiumイメージをブレンドできます。

オーバーレイは、2つのイメージをブレンドします。これはSketchUpからエクスポートしたイメージとPodiumでレンダリングしたイメージをブレンドする際に効果を発揮します。機能を動作させるには、オーバーレイした2つのイメージが同じ解像度でなければなりません。

これを試すには、SketchUpのエクスポート/2Dグラフィックコマンドを使い、SketchUpモデルを2Dイメージにエクスポートします。

次に「オーバーレイをロード」を クリックし、SketchUpで作成したイメージを選択します。オーバーレイスライダを動かして2つのイメージをブレンドします。これで、はっきりとしたSketchUpの線エッジとPodiumのフォトリアリスティックなイメージをブレンドできます。

これについてはPIE ビデオチュートリアルで映像を使って説明しています。

名称はDOFですが、この効果は傾斜シフト機能に似ています。ここで、PIE内で楕円形、あるいは長方形のレンズ口径とぼんやりと映る領域用のブラー量を決めて、イメージがはっきり表示される領域を選ぶことができます。ブラーは、レンズ口径の大きさと強度、およびDOF(被写界深度)スライダで制御します。

履歴 ドロップダウンは、変更ログを保守し、編集プロセスの正確な時点の変更の取り消しを可能にします。ただし、一度適用ボタンをクリックしたら、履歴は消去され、履歴 やキャンセルボタンを使って変更を元に戻すことは不可能になります。

この場合、ファイルを閉じてOOPR から以前のバージョンを再ロードするか、Podium Image EditorのFileメニューから手作業での再ロードが必要になります。履歴ログは、プリセットフィルタと連動しません。


背景ロードオプション

ローカルフォルダから背景をロード、またはPodium Image Editorライブラリから1つ選択します。背景を追加する前にまず、透過をオンにしてイメージをレンダリングしなければなりません。

Podium Image Editor 背景ライブラリ: これは、さまざまにカテゴリに分類された数百ものイメージを備えたウェブベースのPodium Image Editorライブラリです。今後、Cadalogはこのイメージライブラリを定期的に追加していきます。

イメージライブラリを使用する場合は、イメージを選択し、虫メガネを使ってイメージサイズを拡大します。次にそのイメージを右クリックします。Set backgroundというオプションが表示されます。このオプションを選択すると、イメージがPIEに背景としてロードされます。背景イメージを追加する前に、PIEにアルファ透過イメージがロードされていることを確認してください。


背景イメージの移動: 背景イメージの移動が、前PIEバージョンよりはるかに簡単になりました。ツールメニューで背景を移動を選択し、その背景イメージをつかんで動かすだけです。


背景イメージのサイズ変更:

背景イメージは、(%、またはピクセル量で)簡単にサイズ変更できます。